[pygtk] Re: Packaging issues

Tiago Cogumbreiro cogumbreiro at linus.uac.pt
Sun Jun 27 18:22:57 WST 2004


On Sun, 2004-06-27 at 09:57, Jonathan Lange wrote:
> Tiago Cogumbreiro wrote:
> 
> > On Sun, 2004-06-27 at 09:18, Jonathan Lange wrote:
>  >
> >>Luca Masini wrote:
> >>>
> >>>I have sucessfully compiled a pygtk/glade program using
> >>>  cx_Freeze 2.2 (released August 27, 2003)
> >>>from http://starship.python.net/crew/atuining/cx_Freeze/index.html
> >>>(you need to install cx_PyGenLib; a needed general libraries too)
> >>>
> >>
> >>When I try this, on Windows, using Python 2.3 and cx_Freeze 2.2, I get:
> >>
> >>File "C:\Python23\Lib\site-packages\gtk-2.0\gtk\glade.pyd", line 4, in ?
> >>   ImportError: cannot import name Widget from gtk._gtk
> >>
> >>The same error occurs in cx_Freeze 2.3. If you can publish your notes, 
> >>please do.
> > 
> > cx_Freeze works, at least for me, I've tested it under linux first and
> > then on windows. I have created a log of this experience (the last one),
> > i have it kept in a very temporary webpage:
> > http://www0.s1x.homelinux.net/documents/Xpython/
> > 
> 
> Thanks Tiago.
> 
> The answer proved to be as trivial as "manually specify gtk.glade in 
> your included modules".
I was figuring it was something like that :) Unfortunately cx_Freeze
doesn't discover pygtk dependencies automatically.




More information about the pygtk mailing list